AJAX 1.0-Enabled ASP.NET 2.0 Web Site?

Mar 4, 2008 at 7:45 AM
I was wondering if the features of DropThings requires the .Net 3.5 or if I can create a site using .Net 2.0 and still implement the CustomDragDrop, WigidContainer, etc?

Basically will it work in .Net 2.0?

Thank for the help,
McFrosty
Mar 4, 2008 at 6:14 PM
I don't think so. He is using LINQ for data access which will only compile in C# 3.0 (VS 2008) because of some new language extensions. I believe LINQ is only part of 3.5. He's also using the new work flow stuff which I think is only in 3.5 as well. It was to take some serious re-engineering on my part to make it work with VS 2005 and .net 2.0 so I pressed the issue and got VS 2008 bought for me. It took me some tinkering today but I now have DropThings running locally.
For that matter parts of the project wouldn't even open in VS 2005 even with 3.5 loaded here.

Hope that helps but probably isn't the answer you wanted to hear. ;)
Eric.
Mar 5, 2008 at 5:22 AM
Your right, its not exactly what I was hoping for but it is what I expected.

No worries though. I've recently worked on more than one project that I couldn't host through GoDaddy for one reason or another. It may be time to find a new host thats more up to date and ASP friendly.

Thanks for the information!
McFrosty