The remote server returned an error: (500) Internal Server Error

Jul 10, 2008 at 10:01 AM
I downloaded the latest code and trying to build it. I am getting below exception at Dropthings\Scripts.ashx:line 65.


System.Net.WebException was unhandled by user code
  Message="The remote server returned an error: (500) Internal Server Error."
  Source="System"
  StackTrace:
       at System.Net.HttpWebRequest.GetResponse()
       at Scripts.ProcessRequest(HttpContext context) in f:\Rajesh\Projects\VS2008\dropthings-src-1.5.0\dropthings-src-1.5.0\trunk\Dropthings\Scripts.ashx:line 65
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
  InnerException:


Any suggetions

Thanks in advance
Rajesh A
Coordinator
Jul 10, 2008 at 4:26 PM

Please update trunk folder and try again. I made a new commit and it should fix it.

If it does not, please download the latest Release V 1.5 zip file.


rajeshaz09 wrote:
I downloaded the latest code and trying to build it. I am getting below exception at Dropthings\Scripts.ashx:line 65.


System.Net.WebException was unhandled by user code
Message="The remote server returned an error: (500) Internal Server Error."
Source="System"
StackTrace:
at System.Net.HttpWebRequest.GetResponse()
at Scripts.ProcessRequest(HttpContext context) in f:\Rajesh\Projects\VS2008\dropthings-src-1.5.0\dropthings-src-1.5.0\trunk\Dropthings\Scripts.ashx:line 65
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
InnerException:


Any suggetions

Thanks in advance
Rajesh A



Jul 11, 2008 at 8:54 AM
Edited Jul 11, 2008 at 8:55 AM
Not working. Same issue. I tried the code in releases tab and latest build from source code tab. Both are giving same issues. It is not problem with machine. I am using vista ultimate and my friend is using xp professional. We both facing same problem.

oazabir wrote:

Please update trunk folder and try again. I made a new commit and it should fix it.

If it does not, please download the latest Release V 1.5 zip file.


rajeshaz09 wrote:
I downloaded the latest code and trying to build it. I am getting below exception at Dropthings\Scripts.ashx:line 65.


System.Net.WebException was unhandled by user code
Message="The remote server returned an error: (500) Internal Server Error."
Source="System"
StackTrace:
at System.Net.HttpWebRequest.GetResponse()
at Scripts.ProcessRequest(HttpContext context) in f:\Rajesh\Projects\VS2008\dropthings-src-1.5.0\dropthings-src-1.5.0\trunk\Dropthings\Scripts.ashx:line 65
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
InnerException:


Any suggetions

Thanks in advance
Rajesh A






Jul 11, 2008 at 8:58 AM
I have the same problem.
Jul 11, 2008 at 8:59 AM
Hi,

Same problem for me.
Jul 11, 2008 at 9:00 AM
When I try to rebuild after this error 500, I got this error :

System.IndexOutOfRangeException was unhandled by user code
  Message="L'index se trouve en dehors des limites du tableau."
  Source="App_Web_7ofho1h5"
  StackTrace:
       à Scripts.ProcessRequest(HttpContext context) dans c:\Projects\PoshBoard Dropt 1.5 V2\trunk\Dropthings\Scripts.ashx:ligne 22
       à System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       à System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
  InnerException:

Jul 11, 2008 at 9:13 AM
Visual studio have some pecular behaviour. When you run the project, by default it will try to open present open page. In your case it is trying to open Dropthings\Scripts.ashx page.

So close that file and set default.aspx page as the start up page and run. Your problem will solve.


Pilosite wrote:
When I try to rebuild after this error 500, I got this error :

System.IndexOutOfRangeException was unhandled by user code
  Message="L'index se trouve en dehors des limites du tableau."
  Source="App_Web_7ofho1h5"
  StackTrace:
       à Scripts.ProcessRequest(HttpContext context) dans c:\Projects\PoshBoard Dropt 1.5 V2\trunk\Dropthings\Scripts.ashx:ligne 22
       à System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       à System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
  InnerException:




Jul 11, 2008 at 9:19 AM
Thanks for the tip rajeshaz09, Now let's study why this error 500 happens.
Jul 11, 2008 at 10:09 AM
The problem is that it cannot find the file MyFramework.js that is referenced in default.aspx

It is

<script src="Myframework.js" type="text/javascript"></script>     

You can change it to

<script src="../Myframework.js" type="text/javascript"></script>

This worked for me.
Jul 11, 2008 at 10:30 AM
Worked for me too, thanks
Jul 11, 2008 at 11:09 AM
It is not working.

BTW: Why do we change? Myframework.js is already in root directory only?

andrewrimmer wrote:
The problem is that it cannot find the file MyFramework.js that is referenced in default.aspx

It is

<script src="Myframework.js" type="text/javascript"></script>     

You can change it to

<script src="../Myframework.js" type="text/javascript"></script>

This worked for me.



Jul 11, 2008 at 12:16 PM
Edited Jul 11, 2008 at 3:32 PM
It works from the debugger, but when I publish the website drag/drop isn't working (IE tells that there's error with DropThingsUI like in the previous discussion). Strange behavior when using page 2 too.

Edit : It's ok for me with the fix explained above, my problem was a IIS configuration mistakes.
Jul 20, 2008 at 6:19 PM

I am using VWD Express 2008 and have 1.5 of DropThings.  I have tried to resolve a Bad Request error on start-up of...

{"The remote server returned an error: (400) Bad Request."}

It happens in Scripts.ashx in the url mapping...

string mapUrlForJS = HttpUtility.HtmlDecode(map.Url).Replace("'", "\'");

HttpWebRequest request = this.CreateHttpWebRequest(fullUrl);

using (HttpWebResponse response = request.GetResponse() as HttpWebResponse)

It would appear that the fullUrl is not being mapped correctly.  The mapping looks like this...

http://localhost:2789/Dropthings//WebResource.axd?d=_w65Lg0FVE-htJvl4_zmXw2&amp;t=633403939286875000

I tried to hardcode the URLPrefix to "/DropThings" thinking it was the second slash as the problem.

Do I need IIS to run this project?

Thanks,

Rob