Widget Restore

Apr 16, 2009 at 9:39 AM
Edited Apr 16, 2009 at 10:00 AM

Hello,

Kind of new to C# side of things, after getting Dropthings 2.1 running and getting rid of a few bugs etc im stuck on a nice little bug..

When you maximize a widget alls good, but when you click on Restore Widget nothing happens.

I assumed that this would have worked by adding Response.Redirect(Request.RawUrl); to no avail....

void IWidgetHost.Restore()

{

this.ReloadWidgetInstanceAfter(() =>

WorkflowHelper.Run<MaximizeWidgetInstanceWorkflow, MaximizeWidgetInstanceRequest, MaximizeWidgetInstanceResponse>(

new MaximizeWidgetInstanceRequest { UserName = Profile.UserName, WidgetInstanceId = this.WidgetInstance.Id, IsMaximize = false }));

this.SetMaximizeRestoreButtons();

this._WidgetRef.Restored();

WidgetHeaderUpdatePanel.Update();

Response.Redirect(Request.RawUrl); <<<<<<<<<<<<<<

}

Any help would be much appreciated...

Graham

Jul 15, 2009 at 8:59 PM
Edited Jul 16, 2009 at 5:20 PM

Hello,

I have exactly the same problem. Any ideas how to fix this?

I tried to debug by putting break points in Collapse, Expand, Maximize, Restore. When I click on Collapse and Expand, the debugger goes in it, but when I do the same by clicking on Maximize and Restore, the debugger never goes in. Even though I see the widget expanding when I maximize, it is strange that the code is not called.

Thanks.

Jul 28, 2009 at 8:47 PM

I have a working solution for this posted here: _http://code.google.com/p/dropthings/issues/detail?id=22

The fix is actually in the MyFrameork.js file.

Jul 29, 2009 at 10:29 AM

This worked.... Not perfect but acceptable..

 

Cheers