Attaching Database issues

Sep 23, 2009 at 2:37 PM
Edited Sep 23, 2009 at 6:39 PM

While trying to attach the database provided (dropthings) to my SQL Server 2005 I got an error related to version issues. Apparently my SQLServer version is 612 while the dropthings db is created with version 655. So I am unable to attach the database and run the project!

 

It would have been much easier if the database is provided as a script because this whole sqlserver thing is very dependent. 

 

What is the solution to this? Not sure if there is a 655 version of SQLServer 2005 and even if there was one upgrading is not an option. 

Sep 23, 2009 at 6:44 PM

Any takers?

Sep 24, 2009 at 10:59 AM

HI

I also Get the same error at attach database.

Had you solve it???

Sep 25, 2009 at 4:07 PM

Hi,

You can attach the MDF file (dropthings.mdf) in the "trunk\src\Dropthings\App_Data" folder using the Attach option in SQL.

OR

use the SQL Query " Restore Database Dropthings from xxx.bak" file and it will be done.

I too had faced this problem but solved it and I remember this was the way.

Let me know if this helps or not.

 

Good luck.

Prasad

Oct 9, 2009 at 7:36 AM

Hi there

Thank you foryour hepl But I already try to do this and I get the same Error

At the attach C:\Dropthings-2.3.2-Deploy\App_Data\dropthings.mdf I get tha same error

At the restore I try to do this I create A new database with the same name  dropthings.mdf and after this I made a rename to the file in this folder  C:\Dropthings-2.3.2-Deploy\Copy\App_Data\dropthings.Bak

I get the error.

Can you help .

Best Regards

Mar 22, 2010 at 1:32 PM

You must use a SQL Server 2008 to attach the mdf file. I use the 2008 Express version, and that works too.

 

Apr 4, 2010 at 10:27 AM

Hi,

I have the same error...

any solutions ?

Jul 5, 2010 at 9:04 AM

niklasringdahl is right. u must install SQL Server 2008 to attach it. it will work.

Aug 3, 2010 at 6:19 AM

i found other way to attach database correctly;

u must use New sqlquery in manage sudio and typed these as follow:

create database lusirs
on
(
filename="E:\mdf\dropthings.mdf"
)
for attach;

it will OK,if u get a message about"System error 5:"5(deny accesss)"

please give u account it proper Authority;

good luck!