1
Vote

Errors when installing Dropthings V2.3.2

description

I downloaded Dropthings from http://dropthings.googlecode.com/svn/trunk/
According to the read.me, I installed the software but encountered 2 problems:
 
Wrong database version

According to readme.txt a database "SQL Server Express 2005" or "SWL Server 2005" is required.
When I start the application, I get the following error:
 
Error occured loading the page. Please ensure you have run the Setup page.
System.Data.SqlClient.SqlException: The database '...\DROPTHINGS_V232\DROPTHINGS\APP_DATA\DROPTHINGS.MDF' cannot be opened because it is version 655.
This server supports version 612 and earlier. A downgrade path is not supported.
Could not open new database 'C:\USERS\ROGER\DOCUMENTS\VISUAL STUDIO 2008\PROJECTS\DROPTHINGS_V232\DROPTHINGS\APP_DATA\DROPTHINGS.MDF'. CREATE DATABASE is aborted.
 
To my opinion, this error occurs because the downloaded database is "SQL Server 2008" and not "SQL Server 2005" ("http://social.msdn.microsoft.com/Forums/en-US/sqlexpress/thread/01ed3b1c-6f29-4518-a3a4-e4e35decc05f/")
 
-> Question: Is somewhere a database available for SQL server 2005 and V2.3.2 ?
 
Namespace "WebTesting" does not exist

When compiling the solution, I get 71 errors because the namespace WebTesting is not available
This namespace exists in the "Visual Studio Team Edition" but I use "Visual Studio 2008 Prof"
My workaround existed in Unloading the project "Dropthings.Test"
 
-> Question: Could someone add in Readme.txt the required versions of VS respectively my workaround for other users

comments

rericson wrote Nov 18, 2009 at 11:43 PM

I have the same error. In below posting I see there is no way I can use this MDF because I have SQL/Server 2005. I would appreciate it if you create a v2005 MDF. Thanks.

http://social.msdn.microsoft.com/Forums/en/vssetup/thread/82f4de5c-d9b4-409b-bcdd-36261363922d

wrote Feb 14, 2013 at 7:54 PM